Angular 2 and Internet Explorer 9 (IE9)

Getting Angular2 and IE9 working together is not very straight forward, since the move to release candidates some of the Shim libraries have been changed and others removed from the NG2 packages making things confusing.

After some research this is what I have determined to be the minimum number of “workaround” libs required. Note I have also included some other imports that are required since the move the RCs.

NPM

The following NPM libraries you will need to install are the following:

npm install --save angular2-ie9-shims
npm install --save core-js
npm install --save zone.js
npm install --save systemjs
npm install --save reflect-metadata
npm install --save rxjs

Script tags

The corresponding script imports are:

  <!-- This first should be temporary -->
  <script src="lib/shims_for_IE.prod.js"></script> 
  <script src="lib/shim.min.js"></script><!-- from core-js -->
  <script src="lib/zone.js"></script>
  <script src="lib/Reflect.js"></script>
  <script src="lib/system.js"></script>
  <script src="lib/Rx.min.js"></script>

This should have things working (for now) in IE9->11

Jul, 03, 2016

0